Debian/Ubuntu: Arreglando problema de Sonido / Fixing Sound problem

Actualizando / Updated


A veces se nos presentan algunos problemas en el sonido en Linux, sobre todo en laptops. A veces el sonido está bajo, o sencillamente, no se escucha nada.

Bueno, esto lo solucioné fácilmente en Ubuntu 7.10 haciendo lo siguiente (siempre dentro de una consola o shell):

Probar inicialmente (así se remueve/rm el módulo/mod de sonido/snd), escribir:





~$
sudo rmmod snd_hda_intel


Debería aparecer un mensaje de error:

ERROR: Module snd_hda_intel is in use

Ir al archivo /etc/modprobe.d/alsa-base:





~$
sudo nano /etc/modprobe.d/alsa-base

Captura en Kubuntu


Luego ir al final de archivo y agregar un # al inicio de la ultima línea para comentar la línea (en la cual aparece "options ..."); similar a como se hace al comentar una línea de repositorios.
Por ejemplo: #options snd-cmipci mpu_port=0x330 fm_port=0x388

Entonces, escribir abajo de ésta, lo siguiente:
options snd-hda-intel model=3stack

Captura en Kubuntu

Guardar el archivo (ctrl+o) y salir con (ctrl+x)

Probando el módulo de prueba del sonido:
modprobe snd_hda_intel

Y para probar todo (usar las teclas de flechas): alsamixer

Nota: Se deberá o reiniciar el sistema de sonido, o bien, reiniciar al equipo... Para que los cambios sean reconocidos.








Updated

Sometimes exist some sound problems in Linux (alsa mixer), especially in laptops. Sometimes the sound is low, or simply, does not exist.

Well, I solved this easily in Ubuntu 7.10 doing the following thing (always inside a console or shell):

Initially test (remove sound module), write:





~$
sudo rmmod snd_hda_intel

A Error message should appear:

ERROR: Module snd_hda_intel is in use


Go to the file /etc/modprobe.d/alsa-base:





~$
sudo nano /etc/modprobe.d/alsa-base

Screenshot in Kubuntu


Then to go at the end of file and one adds # to the beginning of the last line to comment on the line (in which it appears "options...); similar to as it is done on having commented on a line of repositories.

i.e.: #options snd-cmipci mpu_port=0x330 fm_port=0x388

Then, write below of this one, the following:

options snd-hda-intel model=3stack

Screenshot in Kubuntu

Save file (ctrl+o) and to go out with (ctrl+x)

Testing sound module:
modprobe snd_hda_intel

And to try everything (use arrows keys):

alsamixer


Note: It will be necessary restart the sound system, or, restart Ubuntu/Kubuntu... In order that the changes are recognized.
3 comentarios

Entradas populares